Garmaine Staff asked 2 years ago

I have a Frigidaire Professional Series 4300 series AquaSurge with Speed Clean. It seems to start running fine, but then intermittently pauses for varying lengths of time. This usually results in hot, steaming, sometimes-wet…dirty dishes. Sometimes it cleans fine, but this has turned into a rare occurrence. More often than not, the detergent tab can be found ejected but undissolved, somewhere at the bottom of the dishwasher.

I've tried troubleshooting this myself by sticking a camera and light inside and running a cycle. Here is what happened:

0:00 – set the program, shut the door, loud droning sound with nothing visible happening inside

1:00 – sound stops, and nothing happening

2:35 – opened door to have a look

2:55 – shut door and water immediately starts flowing into the dishwasher

4:25 – lower arm starts spinning and spraying

7:30 – upper arm starts spraying but not spinning, top mini arm is spinning and spraying

7:44 – water pressure of upper arm starts varying between normal and low, and top mini arm stops spinning and spraying

7:55 – water stops flowing out of upper arm

10:48 – bottom arm starts spinning / spraying again

12:20 – bottom arm stops, upper arm starts spraying (but not spinning), top arm is spinning / spraying

13:48 – upper and top arms stop abruptly and bottom arm starts shortly after

15:30 – bottom arm stops and upper arms going again

16:50 – upper arms stop, nothing happening

33:15 – my camera stops recording nothing

Any ideas what might be wrong with this thing, or what else I can try to get a better idea?